6

When I was reviewing a question today, I tried to make some changes to the title and content of the question. This is something I have done before with no problem, but this time I ran into an error message:

This edit would have to be a suggested edit.

As I have less than 2000 reputation points, I have always done suggested edits; I lack permissions to do anything but.

What is this error message? It is useless to me,

Could it be related to the fact that I am so close to 2000 points? Has the suggested edit functionality been changed with the recent overhaul of closing/holding questions? Is there supposed to be a checkbox saying this is a suggested edit? I'm just throwing out possible avenues; I really have no idea what the problem is.

A google search for the exact error message string come back with 0 results, though I suspect in a few minutes there will be a single result for this question. This leads some credence to the error being a new backend change (and probably a bug at that), since no one else has run into it yet.

Edit: Now when I go to that specific question, the edit button is disabled. It isn't disabled for other questions, though. Even on a closed (duplicate) question with a user that has reputation 1, I have an active edit button. What is unique about that question?

Edit 2: The question has been edited by someone else, and I now could edit the question if I so choose. Does the suggested edit functionality get disabled if a user with > 2000 reps starts to edit a question?

  • This is funny to me. Edit collisions have historical given horrid error messages but this is a new one. – Matthew Read Jul 10 '13 at 22:54
8

I think what happened here is that there was already a suggested edit pending on that post when you reviewed it. The timeline looks like (all UTC):

  • 18:57 - Suggested edit is proposed.
  • 19:09 - You review the post and try to edit it
  • 19:12 - Suggested edit is reviewed and processed

During that window between 18:57 and 19:12, you would be unable to suggest an edit on that post since there is already one awaiting review. Thus, when you tried to make some corrections to the post in the review queue, it returned an error.

Therefore, I'd say the main problem here is that the text of the error message is very poor. If it had said something more like:

You may not currently suggest an edit to this post because one is already pending.

...then it would have more accurately captured the situation.

  • That makes perfect sense. I must have started an edit process along with someone else, then they submitted it before me, locking the queue and disabling the edit button as well. I do wish the error message was more like your suggestion. – Stephen Schrauger Jul 10 '13 at 19:40
  • @StephenSchrauger: Since you've tagged this bug it should be viewed by the SE team when time permits, so hopefully they'll consider rewording the error to something more explanatory. – eldarerathis Jul 10 '13 at 19:42
  • True. FYI the "main" topic is this, feel free to spread the word and hopefully with enough upvotes the team will act. – Shadow Wizard Sep 2 '13 at 7:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .