4

I've been periodically attempting to merge two tags over the past ~3 weeks - as per the discussion in this Meta question - but have been unable to do so. The first few steps of the merge process work alright: I can select the two tags, and the merge preview gets pulled up correctly, but when I hit the button to actually perform the merge, I get kicked out to the Something Bad HappenedTM page.

If relevant, the specific tags I'm attempting to merge are and , with the former being set as a synonym of the latter.

Additional information that appears to possibly be relevant: there was a synonym suggestion awaiting approval that was going to map to . This is the opposite of the merge we were trying to perform, so I'm suspecting that it was causing the system to bomb out because it couldn't reconcile the attempted merge with the synonym suggestion. I was able to complete the merge by doing the following:

  1. Went into the synonym suggestions and clicked "swap" to reverse the direction of the synonym suggestion
  2. Approved the swapped synonym
  3. Performed a merge
  • I saw the same behavior just now, with an without the synonym. Then I tried the reverse without synonym -- which succeeded. Then I tried renaming it (via merge), which also failed. Interestingly, clockworkmod-recovery (s) showed in the auto-complete, despite the fact that it should not exist any more and is not a synonym either. (It is suggested as a synonym for clockworkmod, however; that suggestion ought to have been removed along with the tag, I would think.) – Matthew Read Sep 15 '14 at 20:21
  • That suggestion was mine. Maybe a couple more votes for it would "push it through" automatically? – Izzy Sep 16 '14 at 14:06
  • 1
    @Izzy I think that synonym suggestion may have been relevant here. I was able to complete the merge by going into the synonym suggestion and reversing it to point the other direction, approving it, and then doing the merge. – eldarerathis Sep 16 '14 at 14:54
  • Good point! And glad it solved that way. Still I'd consider this a bug, as the system should have either resolved it automatically or at least pointed out the "conflict". – Izzy Sep 16 '14 at 15:24

You must log in to answer this question.

Browse other questions tagged .