24

Basically all text on Android.SE and its child meta are showing up as gray when I use Google Chrome, but it appears fine on Firefox.

Chrome:

An answer:

Main page:

Meta:

enter image description here

Firefox:

Main:

enter image description here

Meta:

enter image description here

I'm using Ubuntu.


This is also a problem on Opera:

24
  • 1
    Do you have a local copy of the Roboto font?
    – Hynes
    Commented Jun 19, 2017 at 13:54
  • (Please speak in layman's terms, as I always get lost when trying to read things like that. I have no idea what that means, sorry...)
    – Mithical
    Commented Jun 19, 2017 at 13:54
  • Sorry. Is the Roboto font found within your .local/share/fonts folder?
    – Hynes
    Commented Jun 19, 2017 at 14:00
  • Where would I locate this folder?
    – Mithical
    Commented Jun 19, 2017 at 14:01
  • I'm not entirely sure because I'm not on Ubuntu. I did find this question on Ask Ubuntu about installing fonts.
    – Hynes
    Commented Jun 19, 2017 at 14:03
  • +1: got the same problem here. Reinstalling Chrome doesn't help either. Strangely, on another freshly set-up PC it appears fine.
    – Andy Yan
    Commented Jun 19, 2017 at 15:11
  • 2
    No repro on Chrome 59.0.3071.104 (current official build) on Windows 10.
    – Shokhet
    Commented Jun 19, 2017 at 18:31
  • @Shokhet OP said it's Ubuntu, a Linux distro, not Windows
    – iBug
    Commented Jun 20, 2017 at 5:36
  • 2
    I understood, @iBug. I was reporting that I couldn't reproduce the bug in Windows, in case that's useful to the developers.
    – Shokhet
    Commented Jun 20, 2017 at 6:18
  • Reproduced on Ubuntu 17.04. Makes things very, very hard to read.
    – Makoto
    Commented Jun 26, 2017 at 17:18
  • There's a possibility that the Roboto you're using is broken (refer to this issue on GitHub). You may need to update the font (refer to Hynes' comment or this question)
    – Andrew T. Mod
    Commented Jun 28, 2017 at 5:58
  • I have the entire Roboto family installed and everything is still virtually unreadable: imgur.com/xzthyyV Chrome 59.0.3071.115 Commented Jun 29, 2017 at 21:19
  • 1
    windows 10, Chrome, completely unreadable: imgur.com/a/0MLxj
    – Brad
    Commented Aug 15, 2017 at 21:08
  • 1
    Repro on Windows 10 as well, unusable Commented Aug 20, 2017 at 12:49
  • 2
    Using Google Chrome: unreadable. Using Microsoft Edge: perfectly clear. Using Internet Explorer 11: perfectly clear. Really I have to switch to those "browsers"?
    – lucasvc
    Commented Aug 27, 2017 at 9:24

4 Answers 4

8

I use Arch Linux, and have instaled ttf-google-fonts-git. Roboto has always been a part of the package. But the site still looks awful on my computer. When I was typing this as a comment, I couldn't see what I'm typing well enough. Though I can see this just fine when typing in the Answer section.

If you must use Roboto, please use Roboto-Medium or Roboto-Regular instead of thin or light variants. The site is currently unusable for me. And please set up fallbacks for people who don't have Roboto.

4
  • On Arch, I already had Roboto installed, as well as various other ttf fonts and it worked fine. I installed ttf-google-fonts-git and now I can reproduce the issue. Unless you know you need all the fonts in that (bloated) package, I suggest removing it and installing the notofonts bundle (which includes a load of fonts which work for most, if not all, languages) instead.
    – terdon
    Commented Aug 29, 2017 at 15:22
  • 3
    @terdon Installing or removing font packages to cater to specific websites seems like approaching the problem backwards. Websites should cater to a general userbase, and not require removal of packages that people find useful elsewhere. Where will this approach end? Install package foo to make website A legible, install conflicting package bar to make website B legible?
    – prash
    Commented Aug 29, 2017 at 15:56
  • Oh absolutely! I am not suggesting that's a solution to what is undeniably a bug. I was just surprised since I couldn't reproduce it and noticed that you were using Arch, so I installed the package. Since installing it makes the bug appear and removing it fixes it, I figured I may as well let you know since that might be a decent workaround for you. And having seen your profile, I will bring back the original scripts I wanted to use instead of languages in my previous comment. The notofonts bundle works for all scripts I've tried and I've tried a good many.
    – terdon
    Commented Aug 29, 2017 at 16:01
  • @terdon Ah, I misunderstood. Apologies.
    – prash
    Commented Aug 29, 2017 at 16:03
6

Not a real answer to this, but I've experienced this font issue in at least 3 of my Windows 10 laptops/PCs.

Things common to all those PCs, if I remember correctly, were:

  1. Windows 10, drivers, Chrome, and all software up to date.
  2. Copy of Roboto font family (downloaded directly from Google) installed locally.
  3. Font issue was noticeable not just on Android SE, but even on Google's sites using Roboto.

Issue was gone once I uninstalled the font family from my system. I suppose it was a Chrome-specific issue where the local Roboto family competed with the Google fonts' online version of it.

This could be relevant to Ubuntu as well.

1
  • 2
    That seems to be correct. I have Windows 10 + Chrome + local Roboto. Just uninstalled Roboto and this site is readable again.
    – Mark
    Commented Sep 7, 2017 at 7:56
1

I use the Web Override extension for Chrome to fix this.

enter image description here

Then just add the following to the CSS tab:

body,textarea,input {
    font-family: Arial !important; 
}

p.s. I cannot believe this has not been fixed...

2
  • Worked nicely on the text but not the comment box. Commented Sep 19, 2017 at 7:08
  • Updated answer. Commented Oct 4, 2017 at 18:27
0

Glad to confirm that this issue has been fixed today (2018-01-06) as seen from my 2 Windows devices. I have the Roboto font family installed locally and the issue had plagued Chrome until last night - logged in today and it looks normal again.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .