7

It could just be me, but one thing that's happened since the new design has been launched is that, more than once I've typed out an answer to a question, and then once I've read through it to double-check there's no glaring errors, I go to post the answer, but stop because the button is disabled. I then go through a bit of a rigmarole of searching round the page to see if I've missed ticking any boxes, adding any tags, etc, then copying all the text to clipboard/notepad and then reloading the page to make sure the question hasn't been deleted/closed/migrated, then finally try clicking the button to see what the error message will be - only for everything to post correctly with no problem.

I think this is because, to me at least, the "Post Your Answer"/"Post Your Question" buttons look exactly like disabled "greyed-out" buttons in Windows (and in many web apps), to the extent that I seem to be mentally conditioned to not even consider clicking them until I've looked all round the form to see what I've missed.

Android.SE Post answer button

As an example from a popular web app many of us will be familiar with, here an enabled and disabled button in Gmail, notice which one the Post button on here looks like:

Gmail buttons

Is there a way that the various post buttons can be made to look a bit more "active" perhaps a bit of colour, or something along those lines?

(Firefox 4 on Win7 & Vista, in case it matters)

  • 2
    Upvoted. Concur. – Sparx Apr 18 '11 at 16:31
  • Changes look good, thanks @Jin – GAThrawn Apr 26 '11 at 14:04
7

You make a good point. I have updated the button styling a bit, both on the main site and on Meta. For the main site, I made the button text green, and for Meta they're much darker now.

The changes will be in the next deployment.

  • Thanks, Jin, that should save my confusion! – GAThrawn Apr 19 '11 at 10:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .